DIYstompboxes.com

DIY Stompboxes => Building your own stompbox => Topic started by: sdk on August 29, 2017, 02:39:55 AM

Title: Need some help to repair an MIJ HM-2
Post by: sdk on August 29, 2017, 02:39:55 AM
Hello,
I've got an MIJ Boss HM-2 but it doesn't work properly. When engaged, the sound is fuzzy and the LED is very dim. In bypass mode I get no sound at all. I've jumpered the wires 4 and 5 to accept the PSA adapters. I'm using a 9v 500ma one.
Inside everything looks fine, so I have no idea what can be wrong with it.
Thanks in advance for any help.
Schematic:

(https://s26.postimg.org/g2lekh939/boss-hm2-heavy-metal-schematic.png) (https://postimg.org/image/g2lekh939/)
Title: Re: Need some help to repair an MIJ HM-2
Post by: Mark Hammer on August 29, 2017, 07:58:12 AM
Does it function properly with a battery?
Title: Re: Need some help to repair an MIJ HM-2
Post by: sdk on August 29, 2017, 09:56:09 AM
I bought it on Ebay, it came without the battery jack.
Title: Re: Need some help to repair an MIJ HM-2
Post by: Mark Hammer on August 29, 2017, 12:30:38 PM
You mean no battery snap of the sort that normally fits under the foot treadle?
Title: Re: Need some help to repair an MIJ HM-2
Post by: Govmnt_Lacky on August 29, 2017, 02:37:41 PM
Does it function properly with a battery?

Agreed! Spend the $0.50 and add a battery snap. Retest. If still fuzzy with dim LED then measure voltage at Pin 8 of any of the IC chips. See if you are getting ~8-9VDC. If not, then look at D2 and C2 to start.

Good Luck  ;)
Title: Re: Need some help to repair an MIJ HM-2
Post by: sdk on August 29, 2017, 03:27:00 PM
You mean no battery snap of the sort that normally fits under the foot treadle?
Yup!
Does it function properly with a battery?

Agreed! Spend the $0.50 and add a battery snap. Retest. If still fuzzy with dim LED then measure voltage at Pin 8 of any of the IC chips. See if you are getting ~8-9VDC. If not, then look at D2 and C2 to start.

Good Luck  ;)
I'll solder a new one in but first on sunday, I'm not home now.
Title: Re: Need some help to repair an MIJ HM-2
Post by: Mark Hammer on August 29, 2017, 04:03:27 PM
Agreed.  There are so many tales here from those who posted that "the effect" works with a battery but not with an adaptor.

Keep in mind the HM-2 is a rather oldish pedal. The contacts in the external power jack might be corroded and very high resistance.  I've had plenty of older jacks that didn't behave well.
Title: Re: Need some help to repair an MIJ HM-2
Post by: sdk on September 02, 2017, 07:28:45 PM
Probably a dumb question, but where should I solder the battery wires in? Negative goes to number 5 on the board but I'm not sure where the positive one has to be.
Title: Re: Need some help to repair an MIJ HM-2
Post by: Mark Hammer on September 02, 2017, 09:01:50 PM
There's a pretty good chance that by now someone has posted a gutshot that shows all the wires in full color, and where they go.
Title: Re: Need some help to repair an MIJ HM-2
Post by: sdk on September 03, 2017, 04:09:59 AM
On both battery and power supply I get 9vdc on the pin 8 of the IC's but when powered with a battery the LED doesn't light up and with the power supply same thing as before.
Title: Re: Need some help to repair an MIJ HM-2
Post by: anotherjim on September 04, 2017, 02:22:50 PM
Reference the schematic, and find all those test voltages shown in rectangles. That should be a good trouble shooting start.

Quote
I get 9vdc on the pin 8 of the IC's
Battery ground should be on the ring contact of the instrument input jack socket. It won't connect to the circuit unless a plug is in the socket. Check you have 0v on pin4 of the IC's.
Title: Re: Need some help to repair an MIJ HM-2
Post by: sdk on September 09, 2017, 04:43:09 AM
Voltages I get on the ICs:

(https://s26.postimg.org/6etoxibmt/15049464876041877906415.jpg) (https://postimg.org/image/6etoxibmt/)