Author Topic: Boss RV-5 Digital Reverb not working  (Read 6368 times)

Brainbender

Boss RV-5 Digital Reverb not working
« on: November 23, 2012, 04:53:12 PM »
Hi!
My RV-5 broke. LED is always on, clean signal is unaffected. I opened it and I saw that one IC is fried and has unreadable markings (which I believe is "JAP J" just like one beside. I removed it in hope if I can get some info about it and then solder a new one. I used Boss PS adapter and I'm really confused what happened?! :(
Any info or photos would be appreciated!!
Pictures:





2nd side

slacker

Re: Boss RV-5 Digital Reverb not working
« Reply #1 on: November 25, 2012, 07:04:58 AM »
I asked google for an RV-5 schematic and it found this http://www.stompboxzone.com/forum/viewtopic.php?f=5&t=1625 which might help you. Even if you can't find the same part, now we know what it is someone might be able to suggest an alternative or a work around.
« Last Edit: November 25, 2012, 07:08:48 AM by slacker »

Brainbender

Re: Boss RV-5 Digital Reverb not working
« Reply #2 on: November 27, 2012, 09:49:55 PM »
Yeah, thank you. Looks like I'm looking for S-8520E33MC-BJS-T2, but I can't find any to buy... :icon_rolleyes:
Any ideas?

rezzyrules1

Re: Boss RV-5 Digital Reverb not working
« Reply #3 on: January 20, 2018, 06:02:21 AM »
CAN YOU LET ME KNOW IF YOU FOUND THAT PART FOR THE RV-5 CAUSE ITS 2018 NOW AND I HAVE THE SAME PROBLEM , HOW DID YOU SOLVE IT? :o

Les Turnbull

Re: Boss RV-5 Digital Reverb not working
« Reply #4 on: January 20, 2018, 01:05:40 PM »

Prehistoricman


Brainbender

Re: Boss RV-5 Digital Reverb not working
« Reply #6 on: January 08, 2020, 12:04:29 PM »
I've sent it to service and the man said the CPU is fried and the repair would cost same as pedal... :icon_rolleyes: