Author Topic: Midi Merger problem with Peavey Vypyr 120 and Sanpera pedal  (Read 3335 times)

TauTau

Midi Merger problem with Peavey Vypyr 120 and Sanpera pedal
« on: January 18, 2016, 09:55:53 AM »
Hi,

I've modded my Vypyr amp to be able to get tap tempo commands from the sequencer into the amp, since there's only the dedicated 8-pin connection to the Sanpera pedal, I used a Midi merger. However, the CC commands from the Volume pedal seem to be changed after the merger, it doesn't realy work anymore as pedal, it's like it only has on/off and even those are reversed. By googling the problem I found this thread from here http://www.diystompboxes.com/smfforum/index.php?topic=102792.0 that indicates the same problem (CC messages stripped). Is there maybe a solution to this? I didn't want to resurrect the old thread ;)
Here's what I did in detail:
http://peavey.com/forum/viewtopic.php?f=33&t=42132&p=298981#p298981

slacker

Re: Midi Merger problem with Peavey Vypyr 120 and Sanpera pedal
« Reply #1 on: January 30, 2016, 06:07:31 AM »
Like you suggest in the thread on the Peavey forum perhaps the system isn't only using MIDI. The amp has an 8 pin connector, MIDI only uses 3 pins (2, 4 and 5 on the 5 pin DIN connector) so what are the other 5 doing? You've said three of the extra leads are power for the Sanpera but that still leaves pins 1 and 3 on the 5 pin midi connector, what are they for?
The merger probably has no connections to pins 1 and 3 so whatever is on those pins isn't making it between the amp and pedal. I would try connecting those wires between the 8 pin connectors bypassing the merger, same as you've done for the power wires.

TauTau

Re: Midi Merger problem with Peavey Vypyr 120 and Sanpera pedal
« Reply #2 on: January 30, 2016, 06:25:54 AM »
I thought about this, too... but there's two points that suggests it's happening on the standard midi line:
- In the Sanpera diagram (http://zorkmids.com/Download/SanperaIIBoard01.pdf) pin 1+3 are labelled "NC", so not connected.
- when instead of using the "OUT" using the "THROUGH" of the merger for the connection to the amp, it also works. No change to the 3 additional connections

gusty7

Re: Midi Merger problem with Peavey Vypyr 120 and Sanpera pedal
« Reply #3 on: February 17, 2016, 03:44:42 AM »
The clue is that it works from the THRU but not on the OUT from the merge unit. The merge is modifying the stream of MIDI data before sending it to the OUT.

I had this problem years ago with a project. What happens is that the Merge software tries to compact the data by stripping out the Status bytes (the ones with bit 7 set, 80h and above) whenever two consecutive MIDI messages have the same Status byte (e.g. two Note Ons one after the other). This is allowed in MIDI spec and is called "Running Status".

Merge units do this sort of thing to increase throughput. Two MIDI streams into one can cause a bottleneck if they are both busy, so throwing away repeat status bytes makes sense. But it only works if your MIDI receiving device is compatible with Running Status, and not all are. The Vypyr-Sanpera combination is a closed system that only expects to receive its own data, so Running Status is probably not implemented.

It would be nice if Merge units incorporated a switch to disable this function, but I have not yet found one that does. It would be simple enough to design one, either as a physical standalone box or as software on a PC with MIDI interface.

You could check whether this is your problem by running the output into a MIDI monitor to read the bytes coming through. If there are Status bytes missing in the stream from the OUT that are present on the THRU, that is your problem.

(BTW, you are right: pins 1,2 & 3 of the Vypyr's MIDI socket are not connected to anything)

TauTau

Re: Midi Merger problem with Peavey Vypyr 120 and Sanpera pedal
« Reply #4 on: February 17, 2016, 04:55:06 AM »
yep, I read about running Status... meanwhile I tried the Behringer FCB1010, funny thing is it works, wether Running Status is on or off (it's switchable there) ;)