Author Topic: Weird Boss Looper Pedal Problem. Please Help.  (Read 567 times)

ffud

Weird Boss Looper Pedal Problem. Please Help.
« on: July 06, 2018, 08:51:26 PM »
Hi,

I am trying to repair a Boss RC-3 Loopstation. The dual cocentric pot was broken when I received it so I thought this was going to be an easy pot replace job. Before replacing the pot the center knob (for the rhythm/drum machine) worked fine, but the outside knob (which controls the loop level) was spinning freely. The pedal would play the drum machine sounds but not loops. I assumed because the knob broke in the down position.

I installed a new pot and still got no loop playback. I thought maybe I had a bad solder joint or maybe the little wires/plastic connectors that connect the pot circuit board to the main circuit board were bad. In the process of testing that, I discovered that if the wires to the pot are disconnected entirely then the loops play back fine, but of course no volume control.

I tried jumping the pins that should connect to the outside knob and the loop stops, which I thought seemed good. So I thought I'd see if I could just connect a resistor (100 ohm is what I had handy) between those pins to try to mimic a sliiiightly turned down pot (pedal uses a 50K pot) and I immediately lost all sound same as jumping the pins. Even just touching one of the test leads I connected to those pins with a finger caused the loop volume to go all the way down. Plugging the pot back in (whether its turned up or down) causes the loop volume to turn all the way down. Whenever pot, jumper, resistor, or finger is removed the volume of the loop slowly ramps back up.

This seems pretty weird to me. Anyone have ideas?

(attaching pics of pedal, pins I was jumping, wires I was connecting/disconnecting, the pot and little board, and a drawing of the connections I figured out on the pot board)