Author Topic: Iron Bell Big Muff clone constant static noise  (Read 113 times)

vmaxvmax

Iron Bell Big Muff clone constant static noise
« on: May 16, 2019, 02:15:58 AM »
Hi,
I have just built a clone of the Iron Bell Big Muff pedal. On vero.
It sounds great except for static noise in the form of popping and crackling just above the level of the usual white noise/hiss. It is random in nature but continual.

I have checked the usual suspects, solder joints, changed transistors etc and grounding is complete.

When probing, the noise is present in all stages of the circuit but gets progressively louder through the circuit (as one might expect in line with increases in gain).

When I place a large value capacitor greater than say 470uf between the + and ground on the vero board, the noise is killed. The bigger the cap, the quieter it is so a 1000 if seems to silence it but with space limited, I would rather locate the cause of the problem.

Could this be a DC issue? Any ideas?

Much thanks in advance...

vmaxvmax

Re: Iron Bell Big Muff clone constant static noise
« Reply #1 on: May 16, 2019, 03:16:43 AM »
Addition:

The static noise is only present when no signal is being passed. In other words, it is not present whilst playing - only when the guitar is silent...


Refractions

Re: Iron Bell Big Muff clone constant static noise
« Reply #2 on: May 16, 2019, 04:12:36 AM »
Sounds like DC noise.

Try a new regulated DC supply, or just a 9v battery.

vmaxvmax

Re: Iron Bell Big Muff clone constant static noise
« Reply #3 on: May 16, 2019, 06:35:16 AM »
Thank you for your answer Refractions.

I am already using a steady and good battery supply!

I do agree that it sounds like a DC issue - but what?

antonis

Re: Iron Bell Big Muff clone constant static noise
« Reply #4 on: May 16, 2019, 06:46:55 AM »
Try it with no guitar engaged..
Can't follow your signature changes, Stephen..!!
but I like what follows:
"put the coffee down, Antonis, and nobody will get hurt."
"Arggg, Jim ...."

vmaxvmax

Re: Iron Bell Big Muff clone constant static noise
« Reply #5 on: May 16, 2019, 09:39:24 AM »
Thank you, I have. No difference. When I probed it the guitar was not connected. The noise is definitely being generated in the clone.

Strange that a large capacitor across the battery provided psu kills the noise.

vmaxvmax

Re: Iron Bell Big Muff clone constant static noise
« Reply #6 on: May 16, 2019, 11:10:57 AM »
Phew!

Found it - the L78L05 regulator for the on/off switch relay was faulty...

All clean now.

Thank you all for your kind assistance!