Author Topic: Klon Centaur Klone from aliexpress  (Read 258 times)

ryan.barber

Klon Centaur Klone from aliexpress
« on: February 20, 2021, 07:47:11 AM »
Hello, I have just built my first pedal from a popular klon centaur kit and its not quite working.

When the pedal is off and the cables are going through it to the amp, there is this very loud feedback/buzz. I believe the pedal is in somewhat working condition when on since the led is on, the output knob can vary the level of the buzz and gain and treble potentiometers change the tone of the buzz.

However, it is just a very loud buzz where no guitar can be heard through it.

I have checked the wiring is in the right place many times and there's a few videos on YouTube for this pedal to reassure me the circuit board components are in the correct place.

This is my first time soldering to it may look a bit dodgy but I have checked and there are no connections of two solder points. I didn't have proper wire clippers so the wires of resistors, diodes, etc., come out about 5mm. I would imagine my bad soldering to produce a quiet hum but not an overpowering distorted buzz.

I have the same problem even when I had separated the circuit board from the metal case and laid it on paper incase it is a grounding issue.

This could just be a quick fix but i have no idea what's wrong, any advice would be great.   :)












Marcos - Munky

Re: Klon Centaur Klone from aliexpress
« Reply #1 on: February 20, 2021, 08:33:33 AM »
First of all, welcome!

Now, please tell us you took that 2nd photo, then trimmed those leads before testing the circuit. They may be touching the enclosure and shorting lots of stuff.

ryan.barber

Re: Klon Centaur Klone from aliexpress
« Reply #2 on: February 20, 2021, 08:58:44 AM »
Hi Marcos, I think I should buy a wire cutter to trim it down and start from there lol.

However, removing the circuit board from the enclosure so that the wires are not shorting (and the wires are not touching each other), the buzz is still there and the pitch of the buzz changes when I move the circuit boards orientation. So I am a bit lost on where its going wrong.
Thanks for the welcome and reply :)

Big Monk

Re: Klon Centaur Klone from aliexpress
« Reply #3 on: February 20, 2021, 09:12:48 AM »
Hi Marcos, I think I should buy a wire cutter to trim it down and start from there lol.

However, removing the circuit board from the enclosure so that the wires are not shorting (and the wires are not touching each other), the buzz is still there and the pitch of the buzz changes when I move the circuit boards orientation. So I am a bit lost on where its going wrong.
Thanks for the welcome and reply :)

There are a number of solder joints that look a little dicey. I would reflow the dodgy looking ones and see where you are at.

And to beat the dead horse: clip those leads! They may not be shorting to the Chassis but they may short to each other if you aren’t careful.
“We are what we repeatedly do. Excellence, therefore, is not an act, but a habit.” Aristotle

"Beneath the bebop moon, I'm howling like a loon, for you..." Marc Bolan

ryan.barber

Re: Klon Centaur Klone from aliexpress
« Reply #4 on: February 20, 2021, 09:26:10 AM »
Some good advice there! Thanks Derek, hopefully I can get it working soon.  :D

edvard

Re: Klon Centaur Klone from aliexpress
« Reply #5 on: February 21, 2021, 03:00:18 PM »
Your symptoms sound an awful lot like input leads swapped; Tip to ground and Sleeve to input.  I've done it enough times to know that noise when I hear it and swear at myself while I fix it.  Carefully inspect where your input and output leads are going and make sure; if "black wire" means ground to you, I can see from pics 4 and 5 that is the case. 

If it's not that, clip your leads and inspect all solder pads for any bridges.  There may be something touching that you don't see.
All children left unattended will be given a mocha and a puppy