Author Topic: How to get the copper fill to show in Eagle PCB?  (Read 244 times)

soggybag

How to get the copper fill to show in Eagle PCB?
« on: September 12, 2021, 11:58:49 PM »
I have a board I've designed in Eagle PCB. I've created a polygon named it GND. When I first did this the copper pour filled in. I've made some adjustments since and the pour has gone away but clicking ratsnest doesn't bring it back?

Jarno

Re: How to get the copper fill to show in Eagle PCB?
« Reply #1 on: September 13, 2021, 05:01:19 AM »
It should, what kind of adjustments did you make? Did you by accident remove one of the sides of the polygon?

niektb

Re: How to get the copper fill to show in Eagle PCB?
« Reply #2 on: September 13, 2021, 05:07:23 AM »
Ratsnets ís normally the button to bring it back :)
Unless you turned that setting off in the settings menu

bushidov

Re: How to get the copper fill to show in Eagle PCB?
« Reply #3 on: September 13, 2021, 05:15:35 AM »
Are there no longer any vias or pads on there called "GND" when you made your adjustments? If there isn't, it won't fill out on the screen (at least on version 7.X and back)
"A designer knows he has achieved perfection not when there is nothing left to add, but when there is nothing left to take away."
 
- Antoine de Saint-Exupéry

soggybag

Re: How to get the copper fill to show in Eagle PCB?
« Reply #4 on: September 13, 2021, 11:34:07 PM »
It works fine if ripup; then route everything. But if close and reopen the document the ground plane doesn't show?

temol

Re: How to get the copper fill to show in Eagle PCB?
« Reply #5 on: September 14, 2021, 02:26:32 AM »
It works fine if ripup; then route everything. But if close and reopen the document the ground plane doesn't show?

Ripup or ratsnet?

If you reopen the document you shoud see  dashed outline of the GND fill. To see solid GND fill you have to use ratsnet.


soggybag

Re: How to get the copper fill to show in Eagle PCB?
« Reply #6 on: September 14, 2021, 09:52:26 AM »
I get that but for me what happens is I see the dashed out line of the polygon and clicking ratsnest doesn't do anything. The fill was there previously.

If I ripup and then route, then do a ratsnest the fill comes back.

Jarno

Re: How to get the copper fill to show in Eagle PCB?
« Reply #7 on: September 14, 2021, 11:56:19 AM »
Are all layers on (well the ones that matter, but do you see the fills if you turn them all on)?

GGBB

Re: How to get the copper fill to show in Eagle PCB?
« Reply #8 on: September 14, 2021, 12:57:41 PM »
Do your DRC and ERC pass?
  • SUPPORTER

soggybag

Re: How to get the copper fill to show in Eagle PCB?
« Reply #9 on: September 14, 2021, 06:45:33 PM »
Do your DRC and ERC pass?

Good question! I'll look into that...

deadastronaut

Re: How to get the copper fill to show in Eagle PCB?
« Reply #10 on: September 15, 2021, 04:32:03 AM »
re-draw the 'GND' polygon.

unless you accidentally turned the polygon off in the 'layers' view option...?
https://www.youtube.com/user/100roberthenry
https://deadastronaut.wixsite.com/effects

chasm reverb/tremshifter/faze filter/abductor II delay/timestream reverb/dreamtime delay/skinwalker hi gain dist/black triangle OD/ nano drums/space patrol fuzz//

niektb

Re: How to get the copper fill to show in Eagle PCB?
« Reply #11 on: September 15, 2021, 07:16:19 AM »
Are you sure you got the naming right of your Ground Polygon (and is it exáctly the same are your ground signal)?