Author Topic: dead line6 dl-4  (Read 621 times)

brujo

dead line6 dl-4
« on: January 19, 2022, 10:35:53 AM »
Hi there, I have in my hands a dead dl-4. The owner said that after a long session he left it on during the night and that the day after he can't power it on. As I opened it I found some smd cap cooked. Meanwhile I was waiting for smd components, I try to change those caps with standard polyester caps to see if the problem was just there. In the removing of the smds I think I have slaughter a little some traces specifically c82 that on one side soldered to c84 and on then other side to an inductance,but I can't really understand which pin is which....
Going further on the schematic I saw that in maxx887 output I have almnost 9v instead of the 3.3v of the schematic,and also on the ref pin, is there the diode that gives the voltages reference? could be it the problem there?

here the PSU schematic


 And a few photos of pcb


thankyou all for any kind of help






« Last Edit: January 19, 2022, 10:38:20 AM by brujo »

Mick Bailey

Re: dead line6 dl-4
« Reply #1 on: January 21, 2022, 04:18:39 AM »
I think the MAX887 fitted to these is a fixed 3.3v output. D15 is a schottky rectifier diode and is not mentioned in the spec sheet for voltage reference. Check the input to the regulator on pin 8. If that's 9v then D16 is likely to be shorted and maybe the regulator too.

brujo

Re: dead line6 dl-4
« Reply #2 on: January 24, 2022, 02:30:33 PM »



Hey,this is how components tester see d16..It says 2 diodes,It failed :icon_question:

Mick Bailey

Re: dead line6 dl-4
« Reply #3 on: January 28, 2022, 04:54:36 AM »
Did you check the voltage on pin 8 to confirm? I have an idea that a low-voltage zener shows up on these testers as two diodes - I have the same model and will check.

Edit: I tested a zener on the same model tester and it shows as two diodes just the same. The total voltage drop doesn't add up to the zener voltage - slightly less, just as your tester shows. I don't think that diode is the problem, but you should check the voltage on pin 8 to confirm.
« Last Edit: January 29, 2022, 01:02:28 PM by Mick Bailey »

brujo

Re: dead line6 dl-4
« Reply #4 on: January 30, 2022, 10:22:43 AM »
 it is 9v

Mick Bailey

Re: dead line6 dl-4
« Reply #5 on: January 31, 2022, 04:48:17 AM »
That seems too high, but the maximum input voltage for U14 is 11v, so it's unlikely to be the main source of the problem. I recall the last one I repaired having just over 7v on pin 8 with a functioning pedal. Another check is to measure the voltage drop across the zener. to eliminate it. The best way to troubleshoot these is to power the unit off batteries to begin with. As you're getting 9v on the output of U14 though it seems to me that it's shorted input to output. I checked with the spec sheet for U14 and diode D15 is part of the output rectification circuit and is not used for reference.

What are the the output voltages of U20 and U21?

My approach would be to remove U14 and  apply 3.3v between the indicated test point on C58 and ground, then measure the rest of the DC voltages to see if they correspond to the schematic.