Author Topic: Yet Another MOSFET Boost Popping Question -- HELP!  (Read 2549 times)

railhead

Yet Another MOSFET Boost Popping Question -- HELP!
« on: September 19, 2007, 08:44:32 AM »
Before anyone tells me to search the forums, I can assure you that I did -- and all I turned-up were threads describing things I've already tried, and thread saying people have tried those things to no avail.

So, here it is again: my AMZ MOSFET Boost is popping like a madman when I turn it on and off, and it's totally unusable in this state. Here's what I've done:

1. Changed my 3PDT wiring so that I can ground out the input, like this:


2. Added a 1M resistor between the board input pad and C1 (R6 in the layout below).

3. Removed the LED from the circuit.

4. Switched it off and on dozens of times to try and "release" the pop.


None of those are doing anything to eliminate the pop. Here's my layout:




What can I do? What should I try? HELP!!!

markm

Re: Yet Another MOSFET Boost Popping Question -- HELP!
« Reply #1 on: September 19, 2007, 08:46:45 AM »
The 1M resistor has to be tied to ground.

markm

Re: Yet Another MOSFET Boost Popping Question -- HELP!
« Reply #2 on: September 19, 2007, 08:48:50 AM »
The 1M resistor has to be tied to ground.

I just saw that it is.   :icon_rolleyes:
Perhaps a pull down resistor on the output as well to drain the 100uF output cap.
« Last Edit: September 19, 2007, 08:58:11 AM by markm »

railhead

Re: Yet Another MOSFET Boost Popping Question -- HELP!
« Reply #3 on: September 19, 2007, 10:36:31 AM »
Do I want to drain C5 or C4? C4 is the board out, back to the switch...

markm

Re: Yet Another MOSFET Boost Popping Question -- HELP!
« Reply #4 on: September 19, 2007, 12:44:06 PM »
Do I want to drain C5 or C4? C4 is the board out, back to the switch...

Sorry, the output of the circuit C4.

railhead

Re: Yet Another MOSFET Boost Popping Question -- HELP!
« Reply #5 on: September 19, 2007, 11:14:49 PM »
Update: I added a 1M resistor to the input AND output caps, and that killed the pop.

markm

Re: Yet Another MOSFET Boost Popping Question -- HELP!
« Reply #6 on: September 19, 2007, 11:16:02 PM »
Update: I added a 1M resistor to the input AND output caps, and that killed the pop.

You're welcome!  :D

amz-fx

Re: Yet Another MOSFET Boost Popping Question -- HELP!
« Reply #7 on: September 20, 2007, 06:48:49 PM »
The pc boards that I sell have pads for both input and output pulldown resistors...

-Jack

twangquack

Re: Yet Another MOSFET Boost Popping Question -- HELP!
« Reply #8 on: September 23, 2007, 02:57:04 AM »
The pc boards that I sell have pads for both input and output pulldown resistors...

-Jack

A big "thumbs up" for Jack's pc board for the MOSFET Boost -- no pops here! I loved doing the build with his excellent quality board.  :icon_biggrin:

railhead

Re: Yet Another MOSFET Boost Popping Question -- HELP!
« Reply #9 on: September 23, 2007, 07:17:50 AM »
Yes, Jack's board is nice (of course) -- but it was too big for the situation I was using it for.

amz-fx

Re: Yet Another MOSFET Boost Popping Question -- HELP!
« Reply #10 on: September 23, 2007, 08:17:29 AM »
The latest version is white with a blue silkscreen...  it gives the finished product a unique look!  :icon_biggrin:

1.25" x 1.9" with a center mounting hole



-Jack

railhead

Re: Yet Another MOSFET Boost Popping Question -- HELP!
« Reply #11 on: September 23, 2007, 08:24:51 AM »
That is pretty cool looking -- I just wish they weren't to tall. The board I made is 1.4 x .9, so it doesn't take up near as much room between the pots and jacks, so I'm able to squeeze it into some really tight spaces.

amz-fx

Re: Yet Another MOSFET Boost Popping Question -- HELP!
« Reply #12 on: September 23, 2007, 08:48:55 AM »
The board size was determined by a couple of things...  1.25" was the minimum dimension that my board supplier would make.

Also, the pcb has some options for circuit changes (like the trimpot) and mods that are not shown online (pulldown resistors), which require more board space.

A plastic standoff (like Smallbear sells) fits in the center hole and then attaches to the back of the gain pot so it should fit in almost any box.

Please post a pic of your pedal when you get it finished. I always like to see finished projects!  :icon_biggrin:

regards, Jack

railhead

Re: Yet Another MOSFET Boost Popping Question -- HELP!
« Reply #13 on: September 23, 2007, 02:14:57 PM »
Will do -- and thanks for all the help you've been here, and via email!

sed

Re: Yet Another MOSFET Boost Popping Question -- HELP!
« Reply #14 on: September 30, 2007, 12:32:05 PM »
Update: I added a 1M resistor to the input AND output caps, and that killed the pop.

Does those 1M resistors change the in- and output impedance of the pedal? I too have problem with popping sound in the Mosfet booster. What I like with this pedal is how well it works with the other parts of my rig and that it gives some clarity to the guitar signal. Of some reason i think that is hence to high input impedance and low ouput impedance. Am I right and can I get rid of the pop and still have the great qualities of the booster?

railhead

Re: Yet Another MOSFET Boost Popping Question -- HELP!
« Reply #15 on: September 30, 2007, 03:40:20 PM »
I noticed no difference in sound or quality after the 1M resistors -- the impact of the pulldowns isn't that drastic.

I also forgot to post a pic of the finished product, so here's the first prototype (I haven't taken gut shots yet):



The depth of field -- coupled with a cheap stencil -- made the first 2 letters more blurry than they will be, but like I said, this is the prototype design.

Since it's a clean boost, I'm keeping everything minimalist: no text, chrome knob, shiny white, etc. I wasn't sure how much I'd like it, but I'm actually quite fond of the mod look it has.

=)

sed

Re: Yet Another MOSFET Boost Popping Question -- HELP!
« Reply #16 on: October 01, 2007, 01:29:14 AM »
OK. I will solder those resistors in. Really nice design you have on that box! :icon_wink: