Author Topic: Line 6 Pod X3 Live - black / blank screen  (Read 2236 times)

jimosity

Line 6 Pod X3 Live - black / blank screen
« on: June 01, 2011, 07:35:44 PM »
I've got a Line 6 Pod X3 Live that has the black / black screen - I've tried holding down this and that as recommended by others on the web, tried different Line 6 power supplies, etc.   PC won't "see" the unit, so I can't do a firmware reinstall.

Line 6's support is "take it to an authorized service center".
I've got it apart and I'm not seeing anything obvious after testing some parts and such.
Any ideas?
Jim Rodgers
jim@americanhc.com

iccaros

Re: Line 6 Pod X3 Live - black / blank screen
« Reply #1 on: June 01, 2011, 08:11:22 PM »
I've got a Line 6 Pod X3 Live that has the black / black screen - I've tried holding down this and that as recommended by others on the web, tried different Line 6 power supplies, etc.   PC won't "see" the unit, so I can't do a firmware reinstall.

Line 6's support is "take it to an authorized service center".
I've got it apart and I'm not seeing anything obvious after testing some parts and such.
Any ideas?

you can buy mine.. :) cheep... I don't use it, no matter how I configure it, it comes out sounding the same...
Seriously thought, this is a computer, so there is nothing in there you can really fix. If nothing is burned, then you would need a logic probe and a full schematic with test points to track down where this is broken.. IF the computer will not see it, then the CPU is not talking over its serial port. Since I believe that is built into the cpu they use I would think that its is not fixable, as you can not just buy a Line 6 programed Processor off the shelf.